分享

一道不错的动态规划(1160) - &豪 - C 博客

 素行 2007-05-22

Post Office
Time Limit:1000MS  Memory Limit:10000K
Total Submit:1047 Accepted:456

Description
There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.

Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

 

 

Sample Output

9

 

 

Source
IOI 2000

#include  < iostream >
using   namespace  std;

/*
p表示i到j的建一个邮局的最小值
q表示前i个地点建j个邮局的最小值 
dp方程

                 p[1][i]               (j == 1)
 q[i][j] = {                                                    }
                q[k][j-1] + p[k+1][i]  (j > 1) (k从j-1到i-1)

*/
 

int  p[ 301 ][ 301 ];
int  q[ 301 ][ 31 ];
int  a[ 301 ];

int  main()
{
    
int  V, P;
    
int  i, j, k, l;
    
int  t[ 301 ];
    
int  tmp;
    scanf(
" %d%d " & V,  & P);
    
    
for  (i = 1 ; i <= V; i ++ )
        scanf(
" %d " & a[i]);
    
    
for  (i = 1 ; i <= V; i ++ )
        
for  (j = i; j <= V; j ++ )
        
{
            
if  (i  ==  j)
                p[i][j] 
=   0 ;
            
else
            
{
                l 
=  (i  +  j)  /   2 ;
                p[i][j] 
=   0 ;
                
for  (k = i; k <= l; k ++ )
                    p[i][j] 
+=  a[l]  -  a[k];
                
for  (k = l + 1 ; k <= j; k ++ )
                    p[i][j] 
+=  a[k]  -  a[l];
               
            }

        }

        
    memset(q, 
0 sizeof (q));
    
for  (i = 1 ; i <= V; i ++ )
        
for  (j = 1 ; j <= P; j ++ )
        
{
            
if  (j  ==   1 )
                q[i][j] 
=  p[ 1 ][i];
            
else
            
{
                
if  (i  >=  j)
                
{
                    q[i][j] 
=  q[j - 1 ][j - 1 +  p[j][i];
                    
for  (k = j; k < i; k ++ )
                    
{
                        
if  (q[i][j]  >  q[k][j - 1 +  p[k + 1 ][i])
                            q[i][j] 
=  q[k][j - 1 +  p[k + 1 ][i];
                    }

                }

            }

        }

        
    cout 
<<  q[V][P]  <<  endl;
    system(
" pause " );
    
return   0 ;
}

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。请注意甄别内容中的联系方式、诱导购买等信息,谨防诈骗。如发现有害或侵权内容,请点击一键举报。
    转藏 分享 献花(0

    0条评论

    发表

    请遵守用户 评论公约